Custom-application fails to restart

Home Forums General Custom-application fails to restart

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #32975
    Rina Watanabe


    I have created a custom application to forward the data received by Conduit (MTCDT Series, Firmware 6.0.0) to another PC.
    The custom application was created using ( as a reference.
    This application worked fine when I installed it, but after restarting Conduit, it didn’t work.
    When I checked the Apps tab on Conduit’s website, the custom application appeared and had a status of Started.

    tar.gz has, Install, manifest.json, Start, status.json (Reference:

    Are there any known issues between Conduit restarts and custom applications?
    What should I check to investigate the cause of the problem?


    Hi Rina,

    How did you install your custom app ? What is the process you used ? I am currently struggling with the same kind of problem and the app installation seem a bit unstable to me. So maybe we can check if the issue is the same.


    Jeff Hatch

    Hello Rina,

    Can you check to make sure that the Start script in your application is executable and anything that it is going to try to execute is executable by root? Make sure that once it is installed that the Start script and other executables have execute permissions set on the files.


    Rina Watanabe

    Thanks Bart,

    I follow Reference ( to create a tar.gz file and install the custom application from the [Apps] tab on the Conduit website.
    After following Jeff’s instructions and checking the application’s behavior, I found a file that the custom application application was unable to access. By modifying the source code, the custom application works fine even after restarting conduit.

    Rina Watanabe

    Thanks Jeff,

    I followed your instructions to check the behavior of the custom application and found files that the custom application was unable to access when the conduit restarted.

    The custom application I created was created with reference to (
    In run “query = os.popen(‘lora-query -x session list json file /tmp/sessions.json’)” on L330.
    The custom application does the same thing.
    The inability to access ‘/tmp/sessions.json’ was causing problems when the conduit was restarted.
    After adding “query.readlines()” before opening the file (L331), the custom application worked fine after restarting the conduit.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.