MQTT Messages not showing.

Home Forums Lora Network Server MQTT Messages not showing.

This topic contains 4 replies, has 3 voices, and was last updated by  SL 7 months, 1 week ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #27328

    SL
    Participant

    I’m using mosquitto_sub -t “#” -v to view the messages coming from Lorawan Devices into the Multitech Conduit but no messages appears.
    - I’m sending messages from my Lora end-device (CT Sensor)
    - I can see other packets passing through since the counter is increasing for the gateway.
    - I used Packet Forwarder and know my messages are passing through because they reach TTN.
    - I tried using Public and Private Lora, but no success.

    I’ve gone through the instructions and firmware is 1.6.2 and FPGA is 33.

    Can someone please help?

    #27333

    Steve Kovarik
    Moderator

    Hello Sleung

    To subscribe to the local MQTT Broker the Conduit, the Conduit needs to be
    configured as the “LoRa Network Server”.
    When the Conduit Gateway is configured as a “Packet Forwarder” all packets
    are forwarded to the LoRa Network Server (TTN) and Mosquitto can not be used
    to view any LoRa packets traversing the Gateway nor is there any logging of
    LoRa end-device packets.

    -Best Regards

    #27334

    SL
    Participant

    Hi Steve,

    Yup, under LoRa Mode – Mode, I’ve selected NETWORK SERVER.
    I’ve attached links to images of the setup:
    Lora

    https://i.imgur.com/3y6LU3C.png

    Gateway

    https://i.imgur.com/LTMdH4D.png

    Packets

    https://i.imgur.com/tBxEc0O.png

    mqtt result I see (no messages seen)

    https://i.imgur.com/c7cfv67.png

    Thanks for clarifying about the Packet Forwarder.
    Is there something I’m missing?

    #27335

    Jason Reiss
    Keymaster

    Did you register the device appkey on key mgmt page?

    #27337

    SL
    Participant

    Hey Jason,

    Yup you are correct, I had the wrong settings for my device for the session entry.

    Thank you all for your help, it is working now.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.